One or more of our systems are down.

Major incident www.bilstatistik.se Website API
23.10.2025 16:45 CEST · 1 hour, 2 minutes

Updates

Resolved

We found the root of the issue and we have fixed it.

23.10.2025 · 17:46 CEST
Issue

You are currently unable to access Bilstatistik.se. We apologize for the inconvenience.

We are working hard to resolve the issue and will provide updates here as soon as we have news.

23.10.2025 · 17:07 CEST

← Back